Как исправить ошибку Deprecated: Function set_magic_quotes_runtime()

После переезда на новый хостинг с PHP 5.3.8, некоторые скрипты начали выдавать ошибку “Deprecated: Function set_magic_quotes_runtime() is deprecated in…”.

Deprecated — в переводе с английского означает устаревшее.

Как исправить ошибку Deprecated: Function set_magic_quotes_runtime()

Ошибка “Deprecated: Function set_magic_quotes_runtime()” информирует нас о том , что в следующих версиях PHP функция set_magic_quotes_runtime() будет отключена и нам стоит ее удалить или изменить в своих скриптах.

Функция set_magic_quotes_runtime(0) — это тоже самое, что и запись ini_set(«magic_quotes_runtime», 0). Заменив все вызовы устаревшей функции на ini_set(«magic_quotes_runtime», 0) вы избавитесь от ошибок, а ваши скрипты даже не почуствуют разницы. Магические кавычки будут работать до версии 5.4.0, после чего данная настройка будет полностью удалена.

Закладка Постоянная ссылка.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

два × 2 =